KTM ATV HQ Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
244 Posts
Discussion Starter · #1 ·
hi
i redone the top end of the sx motor and wanted to change the oil pump
i order 2 suction pumps and one pressure pump and the pressure pump is very stiff,is that normal?(i barely can rotate it with my hand)
the suction pump is ok,but the pressure pump is stiff
is that normal?
 

·
Registered
Joined
·
244 Posts
Discussion Starter · #4 ·
i'm referring to part nr. 4,that is the pressure pump,and brand new is very stiff(not in the normal range stiff)
 

·
Super Moderator
Joined
·
2,399 Posts
Check the pump is inserted correct way round. There is a bevelled edge on the pump that must face out (into the cover) also both suction pumps have the same bevelled edge and must be correct. If you have it correct then you can rotate pump easily with fingers when everything is torqued up.
 

·
Registered
Joined
·
244 Posts
Discussion Starter · #6 ·
that's the stuff,the suction pumps worked fine but the pressure one is way to stiff................so stiff that(not mounted in the motor)i can barely turn it by hand
the suction pump had no problems with it,could turn it by hand no worries.....................................that is why i was worried

any way,will order a new one(another one)and see how it behaves
 

·
Registered
Joined
·
1,108 Posts
I seem to remember the pressure pump rotors being pretty tight. I've always just put them in and run them how they come out of the box. I just make sure to check that the pump thickness is within spec relative to the cover depth. They are a very tight clearance there and I had to sand down my last pump just a bit.
 
  • Like
Reactions: owe

·
Registered
Joined
·
244 Posts
Discussion Starter · #8 ·
I seem to remember the pressure pump rotors being pretty tight. I've always just put them in and run them how they come out of the box. I just make sure to check that the pump thickness is within spec relative to the cover depth. They are a very tight clearance there and I had to sand down my last pump just a bit.
ordered a new one also,just to compare the 2
will let you guys know how things go
 

·
Registered
Joined
·
127 Posts
ordered a new one also,just to compare the 2
will let you guys know how things go
I know its a very old thread, but had the same issue.

While doing a rebuilt, the new pump was super tight, an interference fit.

Got another one, same thing.

But one I had bought at a previous date was running freely

So i didnt feel good fitting to a fully rebuilt motor, and got the rally one (its made of steel)

I measured my 90H pump before removing, and it has 2.5 BAR pressure at idle, maybe a little bit less at about 6k rpm (2.4)

Fitted the steel one, same pressures.

I read the bulletin, about clearances, I meausured the case (9.03mm) and the pump was about 8.975/8.961 inner/outer ring, so 0.055mm-0.069mm gap

I have a shim installed, and the spring must be 7 years old
 
1 - 9 of 9 Posts
Top