KTM ATV HQ Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Hi guys, i have noticed my ktm 525xc is losing oil from where the engine case splits in two. At first I replaces the rubber on the electric start thinking it was the problem, but it wasnt and upon looking closer its coming from the crank case seal. Any good ideas apart from opening the engine up and puting a new gasket in? Thanks in advance for any help or advice as always!
 

Attachments

·
Registered
Joined
·
6 Posts
I had the same problem with mine - there is a screw that goes here (circled in red in the picture) - make sure it is there and tight, that provides a seal from the oil getting out under the starter. I have no idea why there is a screw hole there, and it is easy to miss.

IMG_2009-2.jpg
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
Hi! Sorry for the later reply!, I'm going to have a look at this later, I think you maybe right... I did look at the screw and thought no it cant be that simple lol.. But anyway, thanks again, i'll keep you updated, its really appreciated!!!
 

·
Registered
Joined
·
44 Posts
Strange mine dont have any screw here last time i check. many times is the case seal gone bad, and have leack in this specific location. The cause can be to much oil ,or in my case last time i had this issue, was not enouth seal in this location. If is leacking betwen case you can put an epoxy paste to avoid open the engine, I try this last time before i rebuild the engine and it works.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #5 ·
Yes very strange the screw... maybe because mine is an EU model? Anyway I’ve sealed the [email protected] out the screw and the top of the case, not done a pretty job but it should definitely hold. This week I’ll give it a try and update. Thanks again for all your help!
 

·
Registered
Joined
·
1 Posts
Yes very strange the screw... maybe because mine is an EU model? Anyway I’ve sealed the [email protected] out the screw and the top of the case, not done a pretty job but it should definitely hold. This week I’ll give it a try and update. Thanks again for all your help!
Any update? Mine was leaking in the same place. That screw though looks like is comes in the other way as mine had no head and no way to tighten it.
Cleaned the seal and put it back in.
 
1 - 7 of 7 Posts
Top