KTM ATV HQ Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Yesterday I was testing my 525 after I installed the JD jetting kit and diaphragm kit. Everything felt great until I decided to do a small brake stand in the street. I spun the tires for 2 seconds then rolled out of it. A few minutes later, I pulled into my garage and the quad stalled when I had the clutch pulled in. I tried to start it while in 1st w/ the clutch pulled in, but it rolled forward. The clutch won't fully release, the lever feels normal, and the shifter is hard to move sometimes. I bled the clutch but it didn't help. What might be the problem? Busted spring? If the clutch needs to be replaced, I'd like to replace it with a good racing clutch. Any suggestions?
 

·
Registered
Joined
·
21 Posts
Yesterday I was testing my 525 after I installed the JD jetting kit and diaphragm kit. Everything felt great until I decided to do a small brake stand in the street. I spun the tires for 2 seconds then rolled out of it. A few minutes later, I pulled into my garage and the quad stalled when I had the clutch pulled in. I tried to start it while in 1st w/ the clutch pulled in, but it rolled forward. The clutch won't fully release, the lever feels normal, and the shifter is hard to move sometimes. I bled the clutch but it didn't help. What might be the problem? Busted spring? If the clutch needs to be replaced, I'd like to replace it with a good racing clutch. Any suggestions?

I would start by pulling off the clutch cover and checking things out. Once the cover is off, you should be able to physically see the clutch engaging and disengaging. Checking all the springs is a good idea also.
 
1 - 2 of 2 Posts
Top