First Time Dyno (VERY Disappointing HP & Torque)
Page 2 of 2 FirstFirst 1 2
Results 21 to 27 of 27
  1. #21
    Senior Member KTMATVHQ Guru
    Join Date
    Dec 2008
    Location
    Billings, MT
    Posts
    1,043
    Nice! That's a pretty good number on a stock bore machine. Do you know about what compression ratio you ended up with?
    Mine:
    2017 Husky FX 450
    2009 505 SX
    2008 525 XC-modded for mx (currently 450 cylinder)
    Dad's:
    2009 450 SX
    2008 540 XC

  2. #22
    Junior Member Rookie
    Join Date
    May 2012
    Location
    Bend, OR
    Posts
    9
    Those are impressive numbers. Should be an absolute blast to ride.
    2009 525 xc Ohlins steering stabilizer, otherwise stock

  3. #23
    Junior Member Rookie
    Join Date
    Feb 2018
    Posts
    6
    Wow! Those are awesome numbers! I just got my bike running last night with basically same set up, trail porting, oversize valves, carb to 41 , 8/06 cam, hmf slip on, and a thumper 540 kit.
    I was hoping for mid-50s but maybe I can get better!

  4. Remove Advertisements
    KTMATVHQ.com
    Advertisements
     

  5. #24
    Member Rookie
    Join Date
    Nov 2008
    Location
    Mentone
    Posts
    79
    Yeah. Still need some fine tuning after first Glamis run. Little Bog first 1k-1500 RPM's or so. Need larger pilot jet I think. Allen at CT is gonna adjust fix and tune for free in a few weeks. Bike screams mid-top and revs out stupid fast though. Not a hill in Glamis I couldn't go up in 4th tapped fairly comfortably. Some fine tuning and up the front sprocket to 15 tooth should make bike about perfect for my riding style.

    Nice setup my man! I'm sure you'll be at least at my numbers with a 540 kit. Did you do the build yourself?

    Quote Originally Posted by Cw86 View Post
    Wow! Those are awesome numbers! I just got my bike running last night with basically same set up, trail porting, oversize valves, carb to 41 , 8/06 cam, hmf slip on, and a thumper 540 kit.
    I was hoping for mid-50s but maybe I can get better!

  6. #25
    Junior Member Rookie
    Join Date
    Feb 2018
    Posts
    6
    I did, I’ve only ran the first heat cycles so far but I plan to ride it about an hour tonight and several hours Saturday. I hope everything is correct it seemed to fire easy and revved quick.
    I’ll be having John at Racers Edge tune it on Monday.

    What fuel are you running?
    I started it up on 95 but I dont want to run that all the time. If I can get away with 91 I would otherwise 95 it is.

  7. #26
    Senior Member KTMATVHQ Member
    Join Date
    Nov 2015
    Posts
    257
    60HP and 40ft lbs on a 525? Very nice numbers, CT seems to have it together.

  8. #27
    Member Rookie
    Join Date
    Nov 2008
    Location
    Mentone
    Posts
    79
    That's Awesome Dude. Good for you. I can barely even get a carb out sooo lol. Let me know how she does on the dyno?Definitely curious on your results.

    I broke it in on VP 110 currently, but I wont be running it on anything less than VP 100. The quality of Californian gas is too shitty. My build needs minimum 100 octane anyways or close to it to run optimally.

    Quote Originally Posted by Cw86 View Post
    I did, I’ve only ran the first heat cycles so far but I plan to ride it about an hour tonight and several hours Saturday. I hope everything is correct it seemed to fire easy and revved quick.
    I’ll be having John at Racers Edge tune it on Monday.

    What fuel are you running?
    I started it up on 95 but I dont want to run that all the time. If I can get away with 91 I would otherwise 95 it is.


 
Page 2 of 2 FirstFirst 1 2

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •